Applicable to:
- SolusVM 2
Symptoms
An update/upgrade task remains stuck in the UI in the "Running" state.
Cause
This is caused by a task dispatch misbehavior, likely due to a network glitch.
Resolution
-
Ensure the ports are available between Management server and CR:
What ports are required to be opened for SolusVM 2?
If the trash bin icon is available in 'Tasks' (UI) for the upgrade task, press it to cancel and do the following:-
Restart the agent on CR:
# systemctl restart solus-agent
-
Initiate upgrade on Management server again:
# docker exec $(docker ps -q -f name=solus_api | head -n1) php artisan computeResource:upgrade
-
If the icon is not available, do the following first and repeat 1 and 2 steps above:
- Create database backup:
How to create SolusVM 2 database backup? - Access database:
How to access SolusVM 2 database? -
Set the task status as 'failed':
# update tasks set status='failed' where id=ID;
ReplaceIDwith the ID of the task (check in 'Tasks' list)
Comments
Please sign in to leave a comment.