Applicable to:
- SolusVM 2
Symptoms
RabbitMQ container logs contain errors : #docker logs <RABBITMQ CONTAINER ID>
PRODUCT_ERROR: socket() failed (24: Too many open files) while connecting to upstream, client: 10.10.10.154, server: , request: "GET /socket.io/?EIO=3&transport=polling&t=PgiDNbG HTTP/2.0", upstream: "http://10.0.1.7:6001/socket.io/?EIO=3&transport=polling&t=PgiDNbG",
Cause
The issue is caused by the insufficient user limit configuration allocated for Docker Containers and it is not possible to change it manually.
Resolution
An ability to customize the Management Node stack configuration was delivered in Version 2.0.0-38908 ( SVM2-6736 )
Update SolusVM 2 to the mentioned version or above.
Comments
Please sign in to leave a comment.