Email with user details for SolusVM VPS is not being sent when it is created from WHMCS

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Applicable to:

  • SolusVM

Symptoms 

Email with user details for SolusVM VPS like username and password is not being sent when it is created from WHMCS with solusvmpro module configured.

Cause

Welcome Email is not configured for the product/service in WHMCS

Resolution

1. Log into WHMCS
2. Browse to Setup > Email Templates
3. Check Product/Service Messages > Dedicated/VPS Server Welcome Email
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4. Click on Edit icon and verify that mail body is correct. Here are examples of email templates
Click on Save changes
If you need to create a custom template, check WHMCS article https://docs.whmcs.com/Email_Templates
5. After that browse to Setup > Products/Services > Products/Services and click on Edit icon to edit a  VPS product/service
6. In the Details tab find Welcome Email field and select email template Dedicated/VPS Server Welcome Email and Save the changes
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After that create a new VPS and check if the welcome email is sent.

Note: Make sure that Custom Fields for the product are configured

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