Applicable to:
- SolusVM 2
Symptoms
- Compute Resource is in 'Unavailable' status in SolusVM 2
- CR tasks are in 'queued' state
Cause
Incorrect compute_resource_id and auth_token values in /etc/solus/agent.json on Compute Resource
Resolution
- Access SolusVM 2 admin panel
- Find the affected Compute Resource ID at SolusVM 2 > Compute Resources(ID column next to the affected Compute Resource)
- Connect to SolusVM 2 Management node via SSH
- Access SolusVM 2 Database
- Fetch auth_token of the Compute Resource:
MYSQL_LIN: SELECT settings -> 'auth_token' FROM compute_resources where id=CR_ID;
Where CR_ID is the Compute Resource ID from step 2
- Connect to the affected Compute Resource via SSH
- Backup Solus agent config:
# cp /etc/solus/agent.json{,.orig}
- Open the file /etc/solus/agent.json in any text editor and set the values fetched in step 2 and step 5 for compute_resource_id and auth_token correspondingly.
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