Symptoms
- Update or installation tasks remain in Pending state.
-
One-time login link fails with the following error:
# failed to get containers: Error response from daemon: client version 1.43 is too old. Minimum supported API version is 1.44, please upgrade your client to a newer version"]: timeout
For the customers that means that if Docker has been updated to version 29.0, they may be unable to update their SolusVM installation.
Cause
The case has been analysed and confirmed as a product issue with the ID SVM2-6723
Resolution
A permanent fix for this issue was released on Nov-13th, 2025
Important notes:
- In case Docker was previously updated to the latest version - use the "Workaround" section below or contact SolusVM technical support team to resolve the issue.
- Services, websites, and applications running inside VMs will not experience downtime or interruptions.
- In case Docker has not been updated to the latest version - systemd override file will be installed during the self-update process to be able to update Docker in future
Workaround
Note: management will be unavailable for a short period of time due to the restart of the services
1. Run
systemctl edit docker
2. Add the line mentioned below to the top of the file (as per the screenshot attached)
[Service] Environment="DOCKER_MIN_API_VERSION=1.24"
3. Save the file
4. Run
5. Wait for 3-5 minutes for services to be properly initialized
6. Retry the update from UI, if it doesn't work use
systemctl restart docker5. Wait for 3-5 minutes for services to be properly initialized
6. Retry the update from UI, if it doesn't work use
solus -check-update to check for updates and retry again.
Comments
Please sign in to leave a comment.