Applicable to:
- SolusVM 2
Symptoms
- SolusVM 2 VPS does not boot after password reset. The following error is displayed in VNC console:
CONFIG_TEXT: No Bootable Device
- The following error can be found in api container logs:
# docker container logs `docker ps | grep api | awk {'print $1'}`
...
production.ERROR: Primary disk of the server with id 5 not found. {"userId":1,"exception":"[object] (Exception(code: 0): Primary disk of the server with id 5 not found. at /var/www/backend/api/v1/ComputeResourceVm/Models/ComputeResourceVm.php:559)
Cause
Absent entry about VM disk in SolusVM2 database
Resolution
- Connect to SolusVM 2 management node via SSH
- Create missing entries:
# docker exec -ti `docker ps | grep api | awk {'print $1'}` php artisan computeResourceVm:recreate-disks-for-servers
Comments
0 commentsPlease sign in to leave a comment.