SolusVM 2 VPS does not boot after password reset: No Bootable Device: Primary disk of the server with id not found

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Applicable to:

  • SolusVM 2

Symptoms 

  • SolusVM 2 VPS does not boot after password reset. The following error is displayed in VNC console:

    CONFIG_TEXT: No Bootable Device

  • The following error can be found in api container logs:

    # docker container logs `docker ps | grep api | awk {'print $1'}`
    ...
    production.ERROR: Primary disk of the server with id 5 not found. {"userId":1,"exception":"[object] (Exception(code: 0): Primary disk of the server with id 5 not found. at /var/www/backend/api/v1/ComputeResourceVm/Models/ComputeResourceVm.php:559)

Cause

Absent entry about VM disk in SolusVM2 database

Resolution

  1. Connect to SolusVM 2 management node via SSH
  2. Create missing entries:

    # docker exec -ti `docker ps | grep api | awk {'print $1'}` php artisan computeResourceVm:recreate-disks-for-servers

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